RouterOS多IP使用src-nat上网并对应内网IP地址

本教程主要介绍 RouterOS(以下简称ROS)多IP(多拨或者多宽带)使用src-nat上网,并指定内网的IP通过指定线路上网。

平时的教程都是masquerade伪装上网,所以这次星知苑出品的这个教程使用的是src-nat上网,主要是因为src-nat的效率比masquerade的高。

本教程不适合初学者,过程中很多步骤略过怎么配置,初学者请先学习ROS基本配置再过来查看本教程。


教程环境介绍:

1、ESXi6.5虚拟机虚拟ROS、Win7和WinXP

2、ROS多网卡,分别连接2个外网WAN1和WAN2,内网LAN连接Win7和WinXP

3、ROS版本6.44.5

97-1.png


ROS配置:

1、ROS配置路由器地址:192.168.10.1,配置DHCP,使客户机动态获取到IP,这边客户机Win7获取到了192.168.10.254,WinXP获取到了192.168.10.253,网关都是192.168.10.1


2、ROS配置PPPoE拨号,不够添加默认路由的配置 ,分别添加PPPoE-OUT1和PPPoE-OUT2

97-2.png


3、添加PPPoE-OUT1和PPPoE-OUT2的路由,IP --> Routes,并做标记,这边我标记为out1和out2

97-3.png


4、IP --> Firewall --> Mangle设置规则,内网IP走指定标记的路由,如192.168.10.254走out1,192.168.10.253走out2。

97-4.png

97-5.png


5、IP --> Firewall --> NAT做src-nat上网。如192.168.10.254通过pppoe-out1上网,192.168.10.253通过pppoe-out2上网,并分别设置好Comment,便于脚本更新外网IP地址

97-6.png

97-7.png

更新外网IP地址脚本,需定时执行(我这里只提供单个IP更新脚本):

:local status [/interface get [/interface find  name="pppoe-out1"] running]
:if ($status=true) do={
:local oldip [/ip firewall nat get [find comment="out1"] to-addresses]
:local newip [/ip address get [/ip address find dynamic=yes interface="pppoe-out1"] address]
:set newip [:pick $newip 0 ([:len $newip] -3)]
:if ($newip!=$oldip) do={
/ip firewall nat set [/ip firewall nat find comment="out1"] to-addresses=$newip
}
}


6、到此可以上网了。

97-8.png

  • 下载列表

目前有 10 条评论

avatar

出去玩玩吧  2020-05-14 22:42 6楼

非常不错啊,期待更多好内容,谢谢! 回复
avatar

游客1235052001  2020-05-07 07:38 5楼

我请教一个问题: 我是用VMware workstation 15 做的,CHR 做路由,VMware workstation 里模拟了 两台电脑 win7, win10.  我怎么设置他们的网卡才能确保win7 和 win10连接的是ROS, 而不是通过VM的DHCP 连出去的? 谢谢! 回复
avatar

星之宇  2020-05-07 09:13

@游客1235052001:这个请用esxi模拟,workstation很久没用了,不太清楚 回复
avatar

游客3079277680  2020-04-27 09:19 4楼

这个回流怎么做啊 回复
avatar

星之宇  2020-04-27 09:35

@游客3079277680:src-nat不用做回流,已经指定出去和进入接口。 回复
avatar

今日头条新闻  2020-04-23 18:47 3楼

文章还不错支持一下 回复
avatar

游客974542891  2020-04-16 20:21 2楼

大佬,问下双线接入,联通200+移动100,用爱快合适还是ros合适,不用负载均衡,国内走联通,国外和pt走移动 回复
avatar

星之宇  2020-04-16 20:22

@游客974542891:会的话ros,不会的话爱快 回复
avatar

游客3031149892  2020-04-02 14:41 1楼

请教个问题,类似于路由器此命令中“ip nat pool internet 115.238.xxx.xxx 115.238.xxx.xxx netmask 255.255.255.252”,将源地址转换为一个地址池,ROS如何配置? 回复
avatar

星之宇  2020-04-02 15:10

@游客3031149892:你这个是固定ip上网https://www.myxzy.com/post-143.html,然后做了src-nat,你可以使用把内网地址改成地址段,比如10.10.10.0/24 回复
昵称
邮箱
主页
提交