RouterOS配置原生IPv6(电信IPv4/IPv6双栈)

无意中发现江苏(苏州)电信的原生IPv6改为有状态的IPv6,那么我使用的RouterOS软路由(以下简称ROS)就可以获取到IPv6的地址了,所以又可以折腾了一波。


一、IPv6介绍

IPv6的地址共有128位,也就是IPv6地址总量一共有2的128次方个地址。/32、/48是IPv6地址的一种表示方式,表示IPv6地址的一个整块,也可以理解为是一个完整的IPv6地址池。在计算IPv6地址数量的时候,/32的IPv6地址数量是2的(128-32)次方个地址,也就是2的96次方个地址。/48的IPv6地址数量是2的(128-48)次方个地址,也就是2的80次方个地址。同理,/64的IPv6地址数量是2的(128-64)次方,也就是64次方个地址。我这里分配到的是/56前缀的IPv6地址池。

双栈(Dual-stack):双栈技术运行IPv4和Ipv6共存在同一个网络。


二、ROS配置IPv6

主要是IPv6配置,IPv4配置略,ROS IPv4通过pppoe上网。

1、winbox,打开IPv6 --> DHCP Client。Interface选择PPPoE拨号连接(我这里是ADSL-PPPoE);Request勾上prefix;Pool Name随便填,如IPv6;Pool Prefix Length填入运营商分配的,我这里是56(一般是64,56,48这3种);勾上“Use Peer DNS”;勾上“Add Default Route”;点击OK

472-1.png


获取成功后的状态为Status:bound

472-5.png


2、winbox,打开IPv6 --> Addresses,点击“+”。Address填入::/64;From Pool选择IPv6(也就是第1步填写的Pool Name);interfac选择LAN端口(我这边选择Bridge);勾上“Advertise”;点击OK

472-2.png


三、IPv6测试

测试网址:http://test-ipv6.com/

472-3.png

472-4.png


by 2019-01-08

补充1个ipv6配置截图:

472-6.png

  • 下载列表

目前有 63 条评论

avatar

游客1862301756  2020-11-10 20:39 20楼

大佬出个二层无线路由器配置,我现在就遇到个问题,ros二层路由由已经分配ipv6地址,但无法访问外面的ipv6的问题 回复
avatar

星之宇  2020-11-10 20:42

@游客1862301756:当前建议运营商的双栈ipv6不是太稳定,还是直接用ipv4吧。 回复
avatar

游客1863540372  2020-09-09 23:08 19楼

根据你的操作指导:winbox,打开IPv6 --> DHCP Client.  我使用的是microtik RB750Gr3, winbox版本 v6.45.9,在该软件内没有发现“IPV6”这个菜单或者选项。导致后续没有办法操作,求具体指导 回复
avatar

星之宇  2020-09-10 05:18

@游客1863540372:你没装这个ipv6插件 回复
avatar

游客1863540372  2020-09-10 21:12

@星之宇:非常感谢,已经发现升级包里 IPV6是需要单独安装启用的 回复
avatar

游客1034129968  2020-08-22 13:42 18楼

您好,大佬,ROS的IPV6配置成功后。每当PPPOE重新拨号后,windows系统下的IPV6便无法使用,只有手动重启windows中IPV6服务后才能正常使用,请问这个能解决么? 回复
avatar

星之宇  2020-08-22 13:43

@游客1034129968:这个是windows的原因。只要断一下网卡再连接就好。 回复
avatar

游客1034129968  2020-08-22 14:20

@星之宇:PPPOE重新拨号是路由器的问题还是运营商的问题?以前三四天重新拨号一次还能忍。现在一天能重播个七八次。。。 回复
avatar

星之宇  2020-08-22 14:21

@游客1034129968:单播应该部分地区可以调的时长的,多拨后可能不定时掉,你可以打个10000问问是否可以设置。如果还有这个问题停掉ipv6吧 回复
avatar

游客2018734389  2020-07-10 03:38 17楼

我是ipv6设置正常,但打开网页很慢,光猫拨号是正常的。 回复
avatar

星之宇  2020-07-10 08:58

@游客2018734389:那就不要使用ipv6,光猫拨号应该是不开启ipv6的 回复
avatar

游客1903044234  2020-07-10 09:18

@星之宇:你好,有的,光猫拨号是有开启的,在光猫里确认有开启ipv4&ipv6,光猫是桥接模式,拨号后很正常,但有ros,网页就解析不出来,DNS什么的都正常,请问可留个QQ吗? 回复
avatar

星之宇  2020-07-10 09:19

@游客1903044234:那就不要开启ipv6,因为ipv6各个地方技术有区别的。所以ros不一定支持所有地区的ipv6 回复
avatar

游客1967019533  2020-07-08 21:46 16楼

一样苏州的,我是ros主路由,openwrt旁路由,电脑能获取到ipv6地址,但是ipv6测试通过不了,显示“IPv6 基本正常,但较大的数据包传输失败,这可能导致部分网站显示不全。询问你的运营商是不是 MTU 的问题,这可能与你的隧道有关。 检查你的防火墙,确保已放行 ICMPv6 消息”
外部ping不通电脑的ipv6或ros的ipv6地址,内网可以相互ping通,不知道是不是防火墙哪里有问题 回复
avatar

星之宇  2020-07-09 15:25

@游客1967019533:ROS在ipv4 dns中配置dns v6的解析,不然无法使用v6 回复
avatar

游客1967019533  2020-07-09 18:00

@星之宇:不是dns的问题,我试了也一样的,之前就可以解析ipv6的地址,这个我之前验证过,昨天我还试了不用路由器直接电脑拨号是没问题的,另外使用在线ping工具一样ping不通ipv6地址,但是ipv6测试能通过,用了路由器ipv6测试通过不了,"IPv6 大数据包传输测试" 超时,有用到smartdns,应该跟dns没什么关系 回复
avatar

星之宇  2020-07-09 18:02

@游客1967019533:单ros应该没问题,用lede就不要用v6,很多插件不支持。 回复
avatar

游客1967019533  2020-07-09 18:49

@星之宇:是的,本来准备给pt用的,等ipv6普及度上去了折腾也不晚 回复
avatar

游客3030608962  2020-03-23 13:21 15楼

大佬能否出一片文章详细介绍下 光猫作为拨号的一级路由 ros作为二级路由中继ipv6的文章 对于ipv6的知识实在太少 网上都是ipv4的中继 似乎很ipv6区别还是蛮大的 回复
avatar

星之宇  2020-03-23 13:23

@游客3030608962:光猫不建议作为一级路由,如果运营商能改尽量桥接,不然设备多了光猫肯定挂,而且做端口映射也是问题。 回复
avatar

游客1961766324  2020-01-09 20:51 14楼

上海电信成功,感谢 回复
avatar

游客1875501148  2019-11-25 11:12 13楼

由于设置了ipv6,我内网主机都暴露在外网,这个如何设置防火墙规则来保护安全,请教@星之宇  谢谢 回复
avatar

星之宇  2019-11-25 12:09

@游客1875501148:其实这个建议你内网主机做安全防护,不然ipv6 firewall设置过滤 回复
avatar

游客1875501148  2019-11-25 17:02

@星之宇:有设置ipv6 firewall策略参考吗?谢谢 回复
avatar

星之宇  2019-11-25 17:57

@游客1875501148:没有,一般官网论坛 回复
avatar

游客986938674  2019-07-12 14:18 12楼

苏州电信你这边ROS拨号获取ipv6前缀依然正常吗?我这边ROS已经无法获取ipv6前缀了,还会导致pppoe拨号掉线 回复
avatar

星之宇  2019-07-12 15:29

@游客986938674:我这边一切正常,没什么问题。 回复
avatar

游客826823727  2019-07-14 20:30

@星之宇:报修了,最后查出来的结果居然是局端问题,我的账号居然触发了局端ipv6的bug,周末配合电信的人调试了3个小时 回复
avatar

星之宇  2019-07-14 20:31

@游客826823727:好吧,反正江苏这边ipv6现在设置也不合理,过期时间太短。 回复
avatar

游客986938674  2019-07-08 15:58 11楼

苏州电信今天突然无法获取前缀了,只能获取 /64的v6地址了,不知道怎么回事 回复
avatar

星之宇  2019-07-09 15:20

@游客986938674:我这边依然正常,/64也没事,反正用不完。 回复
avatar

游客1867856925  2019-07-04 08:55 10楼

你这个是ND自动通告的无状态配置,请问怎么配置PD有状态模式,就像DHCPv4一样,服务器给客户端一个完整的地址并记录在案, 回复
avatar

星之宇  2019-07-04 13:50

@游客1867856925:和dhcp一样的话,那就配置DHCPv6 relay啊。 回复
avatar

游客988909469  2019-07-01 15:08 9楼

扬州这边分配了公网ipv4就不给ipv6唉 回复
avatar

游客2028381277  2019-04-24 23:50 8楼

我的IPV6配置以下
/ipv6 address
add from-pool=pool/ipv6 interface=bridge/local
/ipv6 dhcp-client
add add-default-route=yes interface=ether1/wan pool-name=pool/ipv6 pool-prefix-length=62 request=address,prefix
/ipv6 nd
set [ find default=yes ] advertise-dns=yes
怎么二级路由获取不到一级路由的IPV6地址。谢谢! 回复
avatar

星之宇  2019-04-25 06:38

@游客2028381277:你这个要设置ipv6 relay 回复
avatar

游客3746180456  2019-04-25 08:54

@星之宇:1级路由器是光猫,现在ros是2级路由要设置ipv6 relay才能让lan口获取1级路由ipv6吗?谢谢 回复
avatar

星之宇  2019-04-25 10:25

@游客3746180456:对的,这个ipv6 DHCP relay就是dhcp转接。其实最好的是光猫改成桥接模式。 回复
avatar

游客2028381277  2019-04-25 19:48

@星之宇:请教下以下ipv6 DHCP relay里的选项应该怎么设置呢?谢谢
Interface:
DHCP Server :
Link Address :
Delay Threshold: 回复
avatar

星之宇  2019-04-25 19:53

@游客2028381277:自己官网看教程,官网的wiki很详细 回复
avatar

Noah Young  2019-06-12 22:44

@星之宇:大佬,你好,我在官网没找到relay相关文档说明,我也是同样的问题,想请教一下relay的配置设置,网上的资料太少了 回复
avatar

星之宇  2019-06-13 05:46

@Noah Young:dhcp中继,不难,网上其他路由器也有介绍的。 回复
avatar

游客3746180456  2019-04-24 19:28 7楼

你好,移动的光猫抜号上网,ros是二级路由器,要怎样设置才能获取光猫的ipv6呢,谢谢! 回复
avatar

星之宇  2019-04-24 21:07

@游客3746180456:ros ipv6 DHCP client设置自动获取就可以了 回复
avatar

游客3746180456  2019-04-24 23:35

@星之宇:可是设置了dhcp6 client  
address选上,lan口的电脑没有获取光猫分配的ipv6前缀ip,请问那里设置出问题了? 回复
avatar

游客2095443009  2019-02-19 15:49 6楼

Use Peer DNS 只是routeros获得了运营商的DNS,在ip/dns 下能看到,现在的问题是我下面接的电脑没法获得dns,显示的ipv6 DNS 是fec0:0:ffff::1 这样的地址。谢谢,如果方便请给我发邮件。 回复
avatar

星之宇  2019-02-19 15:53

@游客2095443009:这个和ipv4有点不一样,电脑端的ipv6 dns默认是路由器的ipv6地址,毕竟路由器也可以当做dns服务器的。 回复
avatar

游客2095443009  2019-02-19 15:58

@星之宇:我如何给电脑指定一个地址呢? 回复
avatar

星之宇  2019-02-19 16:02

@游客2095443009:不需要指定,如果一定要指定的话,当前ros可以在ip dns中设置ipv6 dns。如果一定要在电脑端显示ipv6 dns,这个目前没有什么好的方法。 回复
avatar

游客2095443009  2019-02-19 16:07

@星之宇:非常感谢!!!
我直接用电脑拨号,可以获得IPv6 的DNS地址240e:50:c800:210,运营商是怎么做的呢? 回复
avatar

星之宇  2019-02-19 16:12

@游客2095443009:这个是pppoe服务器技术,一般你用不到。你电脑拨号相对于路由器拨号,路由器也能获取到ipv6 dns,而路由器到电脑相当于内网,用到的是不同的技术,而且现在家用的路由器都对ipv6支持并不好。 回复
avatar

游客1974326674  2020-01-17 00:16

@星之宇:你好,我也是刚入门ROS今天照着这篇帖子配置好了IPV6,发现无法通过域名访问网站,一想肯定是DNS的问题,电脑端没有V6的DNS,然后又翻了很多帖子,发现有一篇帖子有人提到了IPV6选项卡下的ND项,经过一番瞎折腾我把Advertice DNS这个选项勾选了以后设备上可以看到下发下来的DNS了,域名访问也正常了,我不确定我是否还跟着动了些什么别的选项,但是我对这个印象比较深,楼主你可以试试,如果确实可行麻烦通知我,另外我V4和V6运营商都是有下发DNS的,V4的DNS可以通过DHCP服务器更改,v6有没有什么好的办法更改 回复
avatar

星之宇  2020-01-17 10:08

@游客1974326674:如果是ROS配置IPv6,使用默认的IPv6 DNS需要再配置DHCPv6 Client的时候选上use  peer DNS;如果需要手动配置DNSv6,那么请在IPv4 DNS中设置DNSv6即可 回复
avatar

游客2095443009  2019-02-17 11:58 5楼

如何是客户端获得IPv6 DNS ? 回复
avatar

星之宇  2019-02-17 14:41

@游客2095443009:Use Peer DNS这个获取运营商的DNS 回复
avatar

学习者  2019-01-18 13:12 4楼

同苏州 , 无法获取v6 回复
avatar

星之宇  2019-01-18 14:14

@学习者:配置好之后,断开下PPPoE拨号再重连 回复
avatar

游客1967351534  2019-01-07 14:45 3楼

请楼主更新一下ipv6 adress list,ND,routes等设置截图 回复
avatar

星之宇  2019-01-08 15:10

@游客1967351534:已经补充了一个截图,自己看吧。 回复
avatar

游客1969179773  2019-01-02 17:34 2楼

已降级到你说的版本,按你教程上的设置,还是不行啊。我这里电脑拨号V6没有问题。你的Prefix参数哪里来的?如何查? 回复
avatar

星之宇  2019-01-03 08:48

@游客1969179773:这个参数是status里面看到的。 回复
avatar

游客1969179773  2019-01-02 16:00 1楼

本人同大江苏,最新版本,测试不成功,请问你用的啥版本号? 回复
avatar

星之宇  2019-01-02 16:05

@游客1969179773:long term最新版本。但是会造成部分网站访问慢或者无法访问。 回复
昵称
邮箱
主页
提交