当前位置:首页 > 原创作品 > pretty代码高亮插件——pretty for emlog(kindeditor编辑器专用)

pretty代码高亮插件——pretty for emlog(kindeditor编辑器专用)

作者:星之宇 ┊ 时间:2013-3-30 17:44 ┊ 分类: 原创作品 ┊ 阅读:13156 ┊ 评论:8

这个是插件,直接可以在管理中心后台上传插件安装即可。

插件测试:浏览器FireFox,IE6、8、9,Chrome等测试显示正常。

说明:这个专门为本站集成的新版的kindeditor编辑器而开发的前端代码高亮插件。新版本的kindeditor编辑器默认的高亮是pretty高亮。


注:由于换行问题等等,这里修改默认原版的css。

修改是根据我自己的模版修改的,可能宽度不适合所有的模版,如果宽度不合适请修改插件中的prettify.css文件。


pre.prettyprint {
	width: 630px;      //这里宽度修改,根据模版来修改
	margin: 1em auto;
	padding: 1em;
	white-space: pre-wrap;
}


pretty for emlog所有版本:百度网盘 (下载最新版本即可)

kindeditor编辑器传送门:点击这里


更新日志:

[2013-03-30]更新到1.1版本

1.独立js和css,避免删掉kindeditor编辑器后,插件不能使用


[2012-11-05]发布1.0版本

1.这个插件是前端代码的高亮显示,支持emlog5.0.0。

2.主要支持kindeditor编辑器插入pretty代码的前台高亮显示。

3.由于加载kindeditor编辑器自带的pretty.js文件,只能用于kindeditor编辑器前台显示,不能独立使用。

4.修改为自动换行,避免不换行引起的模版错误。


演示:(本站的代码也是用了这个高亮插件的效果)

<?php
echo 'hello world!';
?>
目前有 8 条评论
avatar
nkvv 2012-12-09 10:41回复3楼
如果用kindeditor编辑器里面的插入程序代码功能,如果代码过长,会撑破表格
avatar
星之宇 2012-12-09 10:43回复
@nkvv:这个我应该修复了的,我看看
avatar
星之宇 2012-12-09 11:23回复
@nkvv:我刚才新装emlog5.0,kindeditor_emlog_1.5和pretty_emlog_1.0,测试下会换行的。
avatar
nkvv 2012-12-09 10:23回复2楼
我已经换上了最新的kindeitor,下载的pretty_emlog这个文件夹放在什么位置啊?
avatar
星之宇 2012-12-09 10:24回复
@nkvv:后台插件上传这个zip包安装就可以了。
avatar
nkvv 2012-12-09 10:30回复
@星之宇:谢谢了,可以了~!
avatar
nkvv 2012-12-09 09:45回复1楼
你好,请问这个插件怎么使用哦?我是个新手,麻烦指教一下~
avatar
星之宇 2012-12-09 10:03回复
@nkvv:这个插件要换上了新版本的kindeditor编辑器才可以用的。