安装mysql5.5.29安装版时报错

安装mysql5.5.29安装版(mysql-installer-community-5.5.29.0.msi)这个版本是出现报错,错误提示如下:“unable to find a version of the runtime to run this application.

点击查看原图

因为刚开始就没有安装.net framework4.0的错误,所以网上下载.net framework4.0安装了,现在是不报没有安装.net framework4.0的错误,但是直接出现unable to find a version of the runtime to run this application的错误。


通过搜索发现可能是.net framework4.0的版本问题,所以换了个版本的.net framework4.0,问题就解决了。


解决方法:

1.原来的版本虽然也是4.0.但版本号为4.0.30128.1,而程序需要安装net framework 4.0.30319.1,所以直接下载新版本的.net framework 4.0.30319.1安装即可。

PS:对于其他的软件报错还可能需要其他的解决办法:

2.因为.NET Framework 4.0 不包括.NET Framework 2.0,所以可能缺少其他版本的运行库,请安装.NET Framework 3.5(.NET Framework 3.5包含.NET Framework 2.0的)即可。

3.当然可能你的vc库也没有安装完全,请安装vc运行库。


  • 下载列表

目前有 1 条评论

avatar

无锡彩钢瓦  2013-01-05 09:05 1楼

对数据库这方面没有怎么研究啊 回复
昵称
邮箱
主页
提交
订阅